KORG Gadget and MIDI / Background Audio / Ableton Link / problems

Hello together,
as total Newcomer, i had (and have) a lot of questions: https://forum.audiob.us/discussion/18616/what-selection-of-apps-for-a-total-beginner/p1

Esp. I had problems to record MIDI from other Apps into Gadget.
I even wrote to KORG and SoundPrism support:

SP support did answer fast, but pointed to KORG, which was only part of the problem, as I misconfigured MIDI in SP :-D

KORG support answered later and totally wrong, saying that Gadget cannot do this at all and only supports Bluetooth MIDI from external Devices :wink:
Very strange...

Anyway, here is what I found and some problems I have with Gadget (next posting to give me some air):

Comments

  • 13 Comments sorted by Date Votes
  • For Gadget to be able to record MIDI from other Apps like SoundPrism, you need to either enable Background Audio or Ableton Link in the Apps settings'

    Background refresh within iOS plays no role and can stay disabled.

    Enabling Background Audio is not the best solution as it is.
    Gadget then always stays in the Background and iOS shows the flashing "Gadget recording" in a red bar. Always - you cannot stop or change this.
    And, it may be wrong, as any other App with Background Audio enabled may also shows this text in the red bar: This may be wrong, ad the bar always shows the first App with Background Audio enabled that was started, but when you touch the red bar, you open the latest App with it enabled, not the one that is shown in the bar!
    This is very bad in my book.

  • A way to do multiple Audio Takes for comping in Cubasis:

  • The other option is, to enable Ableton Link instead.
    Then, the flashing "Gadget" in the red bar will only be shown when you actually are recording!
    After you stop recording, the red bar will be gone - much better and the only correct indication'
    So, this is the way to go.

    But.

    Enabling Ableton Link, also enables another flashing thing, a bar that gets animated from left to right within Gadget.
    This is enormously annoying and constantly brings me out of rhythm - It just disturbs me to no end.

    Therefore, I begged the KORG support to add an option to disable this flashing bar.
    PLEASEEEE

  • AudioBus can simplify things a lot for you. You can disable background audio in Gadget's settings. If you load Gadget into the audio input (not the midi input), AudioBus will enable background audio in Gadget for only as long as it's loaded in AudioBus. Plus, then you can switch between apps a lot easier using the AudioBus side bar.

  • I had some other problems with KORG Gadget:

    Using MIDI for any Gadget, either in easy or advanced configuration flashes a pop-up that requires you to enable access to the microphone!

    I tested this, and found that access to the microphone is not realy required to be able to record MIDI from other Apps!

    You can disable the access and everything works fine!

    But when you try to change the MIDI configuration of a Gadget again, the popup appears again and prevents it - until you enable access to the microphone again!

    This is a no-go in my book and I now constantly allow and disallow access to the microphone, as I cannot bear Apps having and requiring such access without any need and without me actually using the microphone!

    So, I also begged KORG support to change this behavior!

    In times of enough news about security and bugs and criminals and secret services, nobody needs an App that requires you to enable access to the microphone without any reason!

  • Just keep your tin foil hat firmly in place. That should block any audio leakage due to enabling the microphone.

  • And lastly, I have a problem with Gadgets way to handle recording of imported WAV files.

    It fills the 16 bars, and then the rest is outside the bars.
    To use them, you need to repeat cutting and slices into new sciences.
    This is absurd!

    Esp. because Gadget HAS the code to do this by itself!

    When you add empty scenes and then record you own playing or a MIDI App, it perfectly changes the scenes and continues to record finely.

    So, PLEASE KORG, use that very code also when importing for audio files and split the content into separate scenes automatically!

    BTW, please also add an option, so that Gadget automatically creates new scenes, if required space-wise. Why should I guess how much I need????

    This part, I did not write to KORG support, but will append to the mail now!

  • Or, you could just enable airplane mode when you're using audio apps if you're really worried about it. I wouldn't hold your breath waiting for Korg to do anything.

  • tjatja
    edited May 2017 Vote Up0

    @wim said:
    Just keep your tin foil hat firmly in place. That should block any audio leakage due to enabling the microphone.

    That realy is not a helpful comment.
    Nobody needs such behavior of an app!

  • tjatja
    edited May 2017 Vote Up0

    @AmpApps said:
    A way to do multiple Audio Takes for comping in Cubasis:

    Thanks, still not have Cubasis, just MultiTrack DAW - I bought too much Apps too fast and need some time and also again some money :-D

    But Cubasis is on my list, thank you!

    ;-)

  • wimwim
    edited May 2017 Vote Up0

    Yeh, sorry. Couldn't help myself. Sorry, I just can't take that level of worry seriously. But yes, not helpful. My follow-up was intended seriously though.

  • tjatja
    edited May 2017 Vote Up0

    @wim said:
    AudioBus can simplify things a lot for you. You can disable background audio in Gadget's settings. If you load Gadget into the audio input (not the midi input), AudioBus will enable background audio in Gadget for only as long as it's loaded in AudioBus. Plus, then you can switch between apps a lot easier using the AudioBus side bar.

    Yes, I bought AudioBus and AudioShare, but I want to record in Gadget, as I wrote - and this is not possible In AudioBus! Gadget cannot sit in "OUTPUT"

    ;-)

  • Sure it is> @tja said:

    @wim said:
    AudioBus can simplify things a lot for you. You can disable background audio in Gadget's settings. If you load Gadget into the audio input (not the midi input), AudioBus will enable background audio in Gadget for only as long as it's loaded in AudioBus. Plus, then you can switch between apps a lot easier using the AudioBus side bar.

    Yes, I bought Audiobus and AudioShare, but I want to record in Gadget, as I wrote - and this is not possible In AudioBus!

    ;-)

    True. It will only accept direct input, not IAA or AudioBus input, which is disappointing.

Sign In or Register to comment.