SampleWiz, Geo Synthesizer, and MorphWiz updated
  • YAY!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! I didn't think I would see this day!!! And a Friday at that!! I'm going to have fun this weekend!!! :-D

  • For SampleWiz:

    What's New in Version 1.4 * Now works with Audiobus in the Input, Output or both slots simultaneously. The latter setup allows you to resample the output through an effects app back into SampleWiz!

    • Updated for iPhone 5

    I LOVE the ability to resample through effects!!! This is what made the old samplers of the 90's so much fun!!!!

  • By the way, I noticed that Geo Synthesizer states that there are updates for iOS7, but the other apps don't mention it.... They'll all work fine in iOS7, won't they?

  • Just saw feedback about MorphWiz not working on iOS 5, don't update that one if you are still on iOS 5.... more info coming.

  • Updated Morphwiz does not work on iPad 2, ios 5.1.1. Splash screen and then nothing. This has never happened with any of the multitudes of audio apps I've updated in the last two years on my 'pad. And yes, I've tried all the tricks (reset, delete/redownload, etc.) Anyone else having probs?

  • @Audiojunkie, that was supposed to read iPhone5, not iOS7!

  • Hey, sonosaurus...thanks. Huh! :)

  • Or should I say, huh :(

  • @sonosaurus Ah, thanks for the clarification! :-) Thanks for doing this too!

    By the way, I'm still waiting for the crossfade bug to be fixed and sampling to be improved in Thumbjam! ;-)

  • MmmwahahaMmmwahaha +1 -1 (+0 / -1 )

    Geo + Audiobus = bliss, thanks Sonosaurus for getting this done.

  • Great... i have all apps but deleted them for a while... now they came back! Thank's sonosaurus for take your hands on the audiobus here ;) A general question here: Anyone can load another preset in the geo synth? I can't :(

  • So sorry about the MorphWiz iOS 5 crash snafu. Problem found and fixed, will be submitting an expedited update today.

    @Audiojunkie, I hear you regarding TJ stuff ;)

  • Cool!

  • GEO Synth on iPhone5 it's impossible to change presets :(

  • Yep, the same on my iPhone 5. Also the email, save, load button doesn't work. Plus some other little issues :((

  • @Sinapsya @Galaxyexplorer, I'm not involved with Geo Synth development, but I'll pass that on, thanks for the report.

  • Just checked it out, and you can activate those buttons by pressing in the blank space just to the left of each one. In fact it looks like that applies to all the controls on iPhone5, you have to actually touch to the left of them.

  • @sonosaurus: Yes, you're right! Thx!

  • Great news, many thanks to the developers!!!! A question: i'm missing the recorder in morphwiz. It doesn't exist anymore??

  • @manuhz, that is correct, Jordan and Kevin decided to get rid of the recorder for reasons you'll need to bring up with them. Now that there is Audiobus support they were hoping it wouldn't be quite as missed.

  • great news and glad to have Samplewiz back into my workflow.

  • Great news, many thanks to the developers!

  • I don't know if you can help @sonosaurus but Geo won't load on my Ipad 4 latest OS,I've owned SampleWiz and SpaceWiz for some time and after the Audiobus update I decided to buy Geo. The other two are working but this new install of Geo crashes after the splash screen.

  • I have an iPad 4, iOS 6.1.3 and it works fine. Works ok on the iPad 3 as well, same iOS.

    One thing I've noticed is that you can't rename and save presets!!

  • Thanks @FRibeiro I had to delete the app then cold reboot the Ipad then reinstall the app and that seems to have worked.

  • Gonna try it. Thanks!

    No, same thing... I've done it with iPad 3 and iPad 4 with iOs 6.1.3. Both have the same problem.

  • @sonosaurus Ok, I understand... but is not nice to hear it :((( The recorder function was unbeatable! Any change to see it again on board?

  • Your right @FRibeiro there is definitely a bug that won't let you use the pop up keyboard to name Your presets in Geo hope the devs sort this quickly.

  • Here is another important note about the current version of MorphWiz:

    If you have custom presets you need to continue using now, please wait to update. If you update now, your presets will NOT be lost, but they will not appear in the app until an upcoming update.

  • Here's a tune I made up a while ago that features Geo's native sounds and a few of SampleWiz's sounds both played on the Ipad. Hope you don't hate it too much, I'm very glad to see Wizdom on the 'Bus. http://soundcloud.com/heimie-andthe-spelunkers/happyland

  • Ryan @iosmars has posted a video of it. Its 11 minutes, 7 of which is him erm...discussing it and 4 minutes of extremely entertaining epic fail. Not safe for those who don't like bad language!

    http://main.iosmars.com/2013/07/23/geo-synth-now-with-audiob-wtf/

    @sonosaurus could you pass on (or is there a way we could directly) the problems. I've had a few, too, though not as many:- 1) can't name presets: the keyboard seems inactivated 2) Geo keeps going to sleep or falling off in Audiobus (it doesn't otherwise) 3) the silly positions of load etc on the iphone

    Outside of Audiobus it seems fine

  • It turns out I am actually doing the fixes to Geo this time around, and I've already fixed the menu issues in iPhone5 and the preset text entry problem. We were about to submit the update, but I will look into the Audiobus specific issues.

    Please feel free to more precisely describe the scenarios where you have issues with Geo in Audiobus.

  • How has the stability been for everyone with Samplewiz? I haven't heard of anyone having problems with it yet, so I'm curious.

  • @Audiojunkie No problem but then it's outside of Audiobus.

    @sonosaurus main problem is when swapping apps in Audiobus. If I get everything working its fine until I go into something else. Double tapping home and selecting an app is marginally better than using the audiobus sidebar. It doesn't do it all the time (and if you look at the last 4 mins of Ryan's video at least 1 episode of silence is because I think he's turned BM2 off and had the sound on Geo set to 0. It's the kind of thing you don't notice when you're cussing something out!)

    Ps ipad3 iOS 6. Whatever the latest is. iPhone 5 as well

    Edit: I've also noted that when I'm trying to record in cubasis using Geo as a controller although everything sounds fine nothing records. I have to say its ok if I'm just using it to record and control cubasis on its own

  • @sonoaurus if I load Geo into Audiobus input and Loopy HD in the output I find that Loopy tracks Will no longer switch state until I switch apps with the Audiobus tab then they stay in the same State again so no starting,stoping or recording I'm using a Ipad 4 latest OS.

  • I had success using Geo with Thor, SampleWiz, Alchemy, and Sunrizer with Audiobus. With Nave and Sampletank I get just random notes that play when using Geo to control. I haven't had many issues with the sleep attacks from Geo. I'm using a ipad 2. Of course I have the dead keyboard issue.

  • Dead keyboard... "What, now my keyboard broke?" -Ryan (not an exact quote)

    How tragic, but I LOL'ed

    I'm glad to hear @sonosaurus got recruited to whip these apps into shape

  • @sonosaurus Could you sneak some velocity sensing in there while you're at it?

  • Multitouch: 1) Geo 1.0 had a bug that maybe 1% of the user base would have Geo permanently load when unpacking the initial bundle of persistent data. The workaround at the time was to just delete Geo from your device and re-download it. 2) I suspect that the other bug is something that sonosaurus had alerted me to when I was trying to add Audiobus to Geo many months ago before I quit and moved on: Geo never needed to run in the background before so it didn't background properly (at all actually), but it's a requirement now with audiobus because you have to hop around from app to app setting things up. The bug that Ryan made his video post is a lot like what I had simply lived with and worked around when I got the first version of Audiobus working. and 3) The preset naming bug.

    But I am no longer working on any iOS apps; these bug fixes are in good hands with sonosaurus. I suspect that the real future of this app is not in an update; but in an app that has been rethought in light of how much the landscape changed since Pythagoras started (almost a year before Geo shipped, which was more than a year before the first Audiobus shipped).

  • mgmg4871: random notes from Geo playing? you mean every 16th time you put your finger down on the glass (count them!)? be sure that if you are playing into a 1 midi channel synth, that the channel span is 1.

    Geo can be set to hop across all MIDI channels while playing; which is not a bug, but the only way to do fretless polyphony correctly without ditching MIDI for OSC. (That's how a continuum works internally. Midi has to model everything as 16 piano controllers that each have 1 pitch wheel. But with Geo, every note down can be bent independently -- a pitch wheel per fingertip. As a result, all notes need to be on different channels. MIDI synths suck at handling this scenario, because they are only tested with piano-style controllers.)

  • The "channel span" for MIDI also threw me off for a quite some time...till finally I figured out the pattern that the notes were being played every 3rd time for me. On poking around the settings I saw that the MIDI channel span was 1-3 ( something like that , dont have it in front right now ) and then once I made it back to 1 , all the notes played as usual

  • @rrroobb & @thepinkelefant Thanks. I was at a total lost.

  • Geo Synth and Morphwiz bugfix updates are now available in the store!

    For Geo, this fixes the menu problems on iPhone5 and the preset text entry problem. I still haven't been able to reproduce any of the Audiobus sleepy-time issues, so any fixes there will be in a future update.

    For Morphwiz this fixes the crash on iOS5, as well as restores any user presets you had from the old version, and lets you load new presets via email, etc.

  • Not yet in the UK.

    EDIT: It's there now, thanks!

  • Thank you!

  • I have problems reloading my saved patches into Geosynth. Even after uploading them with iTunes, they don't appear in the preset list. Anyone else have this problem?

  • Am I missing something with the MorphWiz update - don't seem to be able to delete custom presets and you can't overwrite existing ones with the same name - you just get a duplicate?

  • @nedmcgowan sorry to hear that, it'd be great could you send some more info about your issue to bugs(at)weareroli(dot)com - thanks!

  • @sonosaurus Upps...not nice to hear it. The recorder function was unbeatable :( Any change to see it again on board?

  • Anyone managed to successfully control Sampletank with Geo Synth ?

    Works great with Thumbjam and Soundprism :(